Convertir des formats de dates avec Excel (anglais, français, américain…)

2
97348

Sous Excel, pour convertir une date dans un autre format il existe plusieurs méthodes. En voici quelques unes avec des exemples de données sources et de résultats obtenus.

Soit B2 la cellule d’origine comportant la données à traiter :

05/01/2015

 

Convertir des dates JJ/MM/AAAA vers AAAAMMJJ

=TEXTE(B2;"aaaammjj")

Permettra de supprimer les caractères « / » et donnera

20150105

Convertir une date au format américain vers le format français ou anglais

Pour convertir des dates de type MM/JJ/AAAA en JJ/MM/AAAA, c’est très simple.

Soit A1 la cellule d’origine comportant la données à traiter :

8/24/2019

Pour obtenir 24/08/2019 saisissez dans la cellule cible :

=TEXTE(SI(ESTTEXTE(A1);DATE(DROITE(A1;NBCAR(A1)-TROUVE("/";A1;TROUVE("/";A1)+1));GAUCHE(A1;TROUVE("/";A1)-1);STXT(A1;TROUVE("/";A1)+1;TROUVE("/";A1;TROUVE("/";A1)+1)-TROUVE("/";A1)-1));DATE(ANNEE(A1);JOUR(A1);MOIS(A1)));"jj/mm/aaaa")

Autre méthode, mais beaucoup robuste, si les jours et mois sont exprimés sur 2 digits (exemple 08/24/2019 et non 8/24/2019)

=DATE(DROITE(A7;4);GAUCHE(A7;2);STXT(A7;4;2))

 

Convertir une date au format français vers le format américain

Soit A1 la cellule d’origine comportant la données à traiter :

24/10/2019

Pour obtenir 10/24/2019 saisissez dans la cellule cible :

=TEXTE(F1;"mm/jj/aaaa")

 

2 COMMENTAIRES

LAISSER UNE REPONSE

Please enter your comment!
Please enter your name here